TransTools For Visio (Free Version) — Full Reference

TransTools for Visio (free) is a Visio file (opened as a regular Visio drawing) that allows you to extract translatable
text from Visio drawings (all formats supported by Microsoft Visio) and to merge translations back into original Visio
drawings.

How does it work?

TransTools for Visio is a normal Visio file. Depending on your version of Visio, usage is slightly different:
e Visio 2010 and newer versions:

Open ‘TransTools for Visio (free)’ file with Microsoft Visio (extracted from the ZIP package which can be
downloaded from TransTools Download page).

The very first time you open it, after you enable macros (using ‘Enable Content’ button), the program will
configure the new Office ribbon interface for you. You will be prompted to resave the file. Choose ‘Current
Visio Format’ and then close the file and re-open it. All the commands will appear under the Add-Ins tab. You
need to do this only once.

To process a file, open Visio files you would like to process (from the same application window - double-click
files in Windows Explorer or open with File -> Open...), and switch to TransTools for Visio (free) file (View tab,
Switch Windows menu). Then select the required command from TransTools group under the Add-Ins tab.
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e Visio 2007 and older versions:

Open ‘TransTools for Visio (free)’ file with Microsoft Visio (extracted from the ZIP package which can be
downloaded from TransTools Download page). This will add 'Trans Tools' menu at the top of the application
window. Open Visio files you would like to process (from the same application window - double-click files in
Windows Explorer or open with File -> Open...), and switch to TransTools for Visio (free) file (via Window
menu). Then select the required command from Trans Tools menu.
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About TransTools

Supported versions

TransTools for Visio works in Visio 2000 or newer versions, including 64-bit versions of Microsoft Visio.

Differences between TransTools for Visio (Free version) and TransTools
for Visio (Professional version)

TransTools for Visio (Professional version) includes the following features missing from the free version:

e Support for fields like page number, total pages, etc.
e Support for advanced Visio drawings like Gantt charts.

e Paragraph and line breaks are represented by regular breaks in generated translation tables (in the free
version, they are represented by <br/> and <para/> tags).
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¢ To merge translations into drawings, the translation table is selected from a file (in the free version, the
translation table needs to be copied to the clipboard and then pasted into the Translate Using Translation
Table dialogue).

e Translation tables can be prepared for a specific CAT tool. This automatically copies the source column into
the translation column and also hides non-translatable text (source column, header row, instructions, field
tags) from your CAT tool.

e Ability to export all translatable text instead of unique text only. This is useful for calculating word counts.
¢ If you extract text from several drawings, translatable text will be grouped by drawing file.

e Several additional options for generating translation tables.

For the Professional version of TransTools for Visio, use TransTools for Visio.vsd file available as part of the
Automatic installer or the Manual Installation package.

Installation

To install TransTools for Visio (Free Version), download the latest version from
http://www.translatortools.net/download.html (listed at the bottom of the Download page). Please note that active
development of the free version has been discontinued and only major bugs will be fixed in itin the future. If you
would like to use a more feature-rich, latest version, use TransTools for Visio distributed as part of the main
TransTools download (available as Automatic Installer or Manual Installation Package from the Download page),
where TransTools for Visio is available for registered users of TransTools Professional Edition (with a 45-day free trial
period for existing and new users). You can read about the latest features added in TransTools for Visio at this
location.

Features overview

Just like any drawings, Visio drawings often contain a lot of repetitive information. An organisation chart, an
engineering drawing or simply an updated version of a Visio drawing — they all contain repetitions or text that you
translated before. TransTools for Visio's translation commands offer you a new workflow for working with Visio
drawings.

TransTools for Visio contains two special commands: Extract Translatable Text and Translate Using Translation Table.
The first command extracts the text of each individual shape presentin a Visio drawing, and provides a translation
table in Microsoft Word or Microsoft Excel format for you to translate. The second command uses the final translation
table to overwrite the textin the drawing, providing you with a translated version of the drawing. This workflow
dramatically increases speed of your translation, esp. in files containing repetitive information (e.g. organisation
charts), batches of similar files, newer versions of old files, efc.

Translation commands work especially well when combined with CAT software.

Extract translatable text

Command overview

This command extracts text from Visio drawings and creates a translation table in Microsoft Word or Microsoft Excel
format. Combined with Translate using Translation Table command, it will dramatically improve your translation
speed and quality when dealing with Visio drawings like organisation charts, engineering drawings, newer versions
of drawings you translated before, etc.

How it works?

This command processes selected drawing sheets and extracts all unique text from text objects. All this text is then
outputinto a Microsoft Word document or Microsoft Excel spreadsheet as a translation table. After you finish
translating the second column of the translation table (manually or using CAT software), you use Translate using
Translation Table command to merge the translation back into the drawing, producing a fully translated drawing.

Important notes

If text blocks on your Visio drawing have internal formatting (i.e., some words are formatted differently than other
words in the same text block), this formatting will not be retained after you import the final translation table into the
drawing with Translate using Translation Table command. Internal formatting is quite rare in Visio drawings, but if
your drawing contains different internal formatting within the same blocks, itis recommended to restore such
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formatting manually after translation using the original drawing as reference.

Running the command

Extract Translatable Text is launched from TransTools menu at the top of Microsoft Visio application window (in
Visio 2007 or earlier versions) or from the Add-Ins tab (Visio 2010 or newer versions). In order to launch it:

1. If you don't see TransTools menu (Visio 2007 or older versions) or TransTools group under the Add-Ins ribbon

tab (Visio 2010+), open TransTools for Visio (free).vsd which you extracted from the ZIP package
downloaded from TransTools Download page. If you already have Microsoft Visio running, you can do this by
double-clicking this file in Windows Explorer or opening it with File -> Open. This will add "'Trans Tools' menu
at the top of the application window (in Visio 2007 or older versions) or ‘TransTools’ group on the Add-Ins tab
(in Visio 2010 or newer versions).

. Open Visio drawings which you would like to process (unless they are already open). You should do it from

the same application window — double-click files in Windows Explorer or open with File -> Open... (note - do
not start another session of Microsoft Visio by selecting it from Windows Start menu or double-clicking its
Desktop icon).

. Switch to TransTools for Visio (free).vsd by selecting it from Window menu (in Visio 2007 or older versions)

or from Switch Windows menu under the View tab (in Visio 2010 or newer versions).

. Select 'Extract Translatable Text' from TransTools menu (Visio 2007 or older versions) or TransTools group

under the Add-Ins tab (Visio 2010 or newer versions).

Tips for CAT software users

While TransTools for Visio will cut down your translation time by letting you translate unique, non-repetitive text, there
is another way to make it even faster. This is CAT software like SDL Trados Studio , memoQ, Wordfast Pro / Classic,
DejaVu X, etc. Follow this step-by-step procedure:

1.

After the Word / Excel translation table is generated, save the file, open it, and remove the table header and
all columns except the 1st column (with text) and the 2nd column (empty).

. Save the file. This will be your original translation table.
. Translate the file. If your CAT tool works through Microsoft Word (like Wordfast Classic or Trados 2007), you

need to work on a copy of the original file.

. After you finish translation, copy the cells from the translated Word / Excel documentinto the 2nd column of

the translation table in the original file. Your translation table is now ready and you can use Translate using
Translation Table command to merge the translation into the original file.

Options
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1. Files to process: This list will contain every sheet of every file opened in_ Microsoft Visio. Select sheets of
individual drawings that you want to extract text from. You can also click | All [/ None |to select / de-select
all sheets in the list.

2. Word: If this option is selected, a new Word document with the translation table will be created.
3. Excel: If this option is selected, a new Excel spreadsheet with the translation table will be created.

4. Print file and page name: Check this option to print the file name and page name of the current drawing at the
top of the generated Word or Excel document.

5. Print file path: Check this option to print the file path of the current drawing at the top of the generated Word or
Excel document.

6. Print column headings and instructions: Check this option to print column headings and additional
instructions at the top of the generated translation table.

When the appropriate options have been selected, click Continue |. To exit, click | Cancel |

Translate Using Translation Table

This command 'translates' Visio drawings using a translation table created with Extract Translatable Text command. It
will dramatically improve your translation speed and quality when dealing with Visio drawings like organisation
charts, engineering drawings, newer versions of drawings you translated before, etc.

To start translating Visio drawings, please refer to the overview of Extract Translatable Text command. Otherwise,
read on.

How it works?

This command searches a drawing for text blocks. Ifit finds a block whose text matches an entry in the translation
table, it replaces the text of the block with its translation from the translation table.

Important notes

If the text blocks on your Visio drawing have internal formatting (i.e., some words are formatted differently than other
words in the same text block), this formatting will not be retained after you import the final translation table into the
drawing with Translate using Translation Table command. Internal formatting is quite rare in Visio drawings, but if



your drawing contains different internal formatting within the same blocks, itis recommended to restore such
formatting manually after translation using the original drawing as reference.

Running the command

Translate using Translation Table command is launched from TransTools menu (in Visio 2007 or older versions) or
from TransTools group under the Add-Ins tab (in Visio 2010 and newer versions). In order to launch it:

1. If you don't see TransTools menu (Visio 2007 or older versions) or TransTools group under the Add-Ins ribbon
tab (Visio 2010+), open TransTools for Visio (free).vsd which you extracted from the ZIP package
downloaded from TransTools Download page. If you already have Microsoft Visio running, you can do this by
double-clicking this file in Windows Explorer or opening it with File -> Open. This will add ‘Trans Tools' menu
at the top of the application window (in Visio 2007 or older versions) or ‘TransTools’ group on the Add-Ins tab
(in Visio 2010 or newer versions).

2. Open Visio drawings which you would like to process (unless they are already open). You should do it from
the same application window — double-click files in Windows Explorer or open with File -> Open... (note - do
not start another session of Microsoft Visio by selecting it from Windows Start menu or double-clicking its
Desktop icon).

3. Switch to TransTools for Visio (free).vsd by selecting it from Window menu (in Visio 2007 or older versions)
or from Switch Windows menu under the View tab (in Visio 2010 or newer versions).

4. Select Translate using Translation Table' from TransTools menu (Visio 2007 or older versions) or TransTools
group under the Add-Ins tab (Visio 2010 or newer versions).

Tips for CAT software users

While TransTools for Visio will cut down your translation time by letting you translate unique, non-repetitive text, there
is another way to make it even faster. This is CAT software like SDL Trados Studio , memoQ, Wordfast Pro / Classic,
DejaVu X, etc. Follow this step-by-step procedure:

1. After the Word / Excel translation table is generated using Extract Translatable Text command, save the file,
open it, and remove the table header and all columns except the 1st column (with text) and the 2nd column

(empty).
2. Save the file. This will be your original translation table.

3. Translate the file. If your CAT tool works through Microsoft Word (like Wordfast Classic or Trados 2007), you
need to work on a copy of the original file.

4. After you finish translation, copy the cells from the translated Word / Excel document into the 2nd column of
the translation table in the original file. Your translation table is now ready and you can use Translate using
Translation Table command to merge the translation into the original file.

Options
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1. Files to process: This list will contain every sheet of every file opened in Microsoft Visio. Select sheets of
individual drawings that you want to translate using the translation table. You can also click | All [/| None |to
select/ de-select all sheets in the list.

2. Translation Table: The translation table should be entered here. After you translate the two-column table
generated by Extract Translatable Text, copy it into the clipboard (only the first two columns, without the
header) and click | Paste |or press Ctrl+V to paste the text from the clipboard.

When the appropriate options have been selected, click| Replace All |. To exit, close the dialogue.
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