Visio drawing translation tools – Documentation

 Visio drawing translation tools icon Extract Translatable Text and Translate using Translation Table tools provide an easy workflow for translating all translatable text in Visio drawing(s) using a CAT tool or with the help of a standard two-column translation table.

Detailed information about Extract Translatable Text and Translate using Translation Table tools for Visio

How Extract Translatable Text and Translate using Translation Table tools can help you in your work

Extract Translatable Text and Translate using Translation Table tools dramatically improve your translation speed and quality when dealing with Visio drawings like organisation charts, engineering drawings, newer versions of drawings you translated before, etc. Extract Translatable Text tool extracts all non-repetitive text shown on the drawing into a translation table in Word or Excel format, while Translate using Translation Table tool merges the translations from the final translation table back into the drawing, producing a fully translated drawing. Since Visio formats such as VSD, VDX and VSDX lack support in common CAT tools, this workflow will be very useful to all translators who need to translate Visio charts from time to time, including charts embedded in other Office documents. It will also be useful for translators who do not use a CAT tool, since it allows to minimize time translating repetitive text.

Using Extract Translatable Text and Translate using Translation Table tools

How to run the tools

Extract Translatable Text and Translate using Translation Table tools are launched from the Add-Ins tab (Visio 2010 or newer versions) or from TransTools menu at the top of Microsoft Visio application window (in Visio 2007 or earlier versions). In order to run them:

  1. If you don't see TransTools group under the Add-Ins ribbon tab (Visio 2010+) or TransTools menu (Visio 2007 or older versions), open TransTools for Visio.vsd (by default, this file is located under your Documents\TransTools folder). If you already have Microsoft Visio running, you can do this by double-clicking this file in Windows Explorer or opening it with File -> Open. This will add ‘TransTools’ group on the Add-Ins tab (in Visio 2010 or newer versions) or 'TransTools' menu at the top of the application window (in Visio 2007 or older versions).

    Visio drawing translation tools on the ribbon

  2. Open Visio drawings which you would like to process (unless they are already open). You should do it from the same application window – double-click files in Windows Explorer or open with File -> Open... (note – do not start another session of Microsoft Visio by selecting it from Windows Start menu or double-clicking its Desktop icon).
  3. Switch to TransTools for Visio.vsd by selecting it from Switch Windows menu under the View tab (in Visio 2010 or newer versions) or from Window menu (in Visio 2007 or older versions).
  4. Select Extract Translatable Text or Translate using Translation Table from TransTools group under the Add-Ins tab (Visio 2010 or newer versions) or from TransTools menu (Visio 2007 or older versions).

Important notes

  1. By default, TransTools for Visio extracts only one occurrence of repetitive text. If you extract text from several drawings at the same time and your drawings contain cross-file repetitions, these repetitions will not be repeated for each individual drawing and will only appear under the first drawing where they occur. You can avoid this by checking “Export all text for calculating statistics” option. However, if you use this option, you need to remember that you cannot translate repetitions differently because only the first occurrence of repetitions will be used as translation for all drawings processed with Translate Using Translation Table tool.
  2. If text blocks on your Visio drawing have internal formatting (i.e., some words are formatted differently than other words in the same text block), this formatting will not be retained after you import the final translation table into the drawing with Translate using Translation Table tool. Support for internal text formatting should be added in future versions of TransTools for Visio. In the meantime, you will need to reproduce such formatting in the translated drawing manually.

Tips for CAT software users

While TransTools for Visio will cut down your translation time by letting you translate unique, non-repetitive text, there is another way to make it even faster. This is CAT software like SDL Trados Studio , memoQ, Wordfast Pro / Classic, DejaVu X, etc.

To be able to translate the generated translation tables inside a CAT tool, use Prepare for CAT Tool option under Translation Table Format panel. The list displays the most popular CAT tools. If your CAT tool is not indicated in the list but it is possible to avoid importing hidden text in your CAT tool, use “CAT Tool with hidden text filtering support” option.

However, if your CAT tool does not meet the above criteria, you can follow this step-by-step procedure:

  1. After the Word / Excel translation table is generated, save the file, open it, and remove the table header and all columns except the 1st column (with text) and the 2nd column (empty).
  2. Save the file. This will be your original translation table.
  3. Translate the file. If your CAT tool works through Microsoft Word (like Wordfast Classic or Trados 2007), you need to work on a copy of the original file.
  4. After you finish translation, copy the cells from the translated Word / Excel document into the 2nd column of the translation table in the original file. Your translation table is now ready and you can use Translate using Translation Table tool to merge the translation into the original file.

Extracting translatable text using Extract Translatable Text tool

To extract translatable text from a drawing, run Extract Translatable Text tool as described above. You will see the following dialogue:

Screenshot: Extract Translatable Text dialogue

The dialogue has the following options:

  1. Files to process: This list will contain every sheet of every file opened in Microsoft Visio. Select sheets of individual drawings that you want to extract text from. You can also click All / None to select / de-select all sheets in the list.
  2. Extract all text (including repetitions) for calculating statistics: By default, only unique text is extracted from Visio drawings. However, if you need to calculate the amount of text for charging your clients, you need to see all the translatable text, including repetitions. To do this, check this option. Note: when you use Translate using Translation Table tool to translate the drawing based on such translation table, only the first occurrence of each repeating entry will be used for translation, all others will be ignored.
  3. Extract text only: If this option is checked (default), the program does not export simple numbers.
  4. Translation Table format: the format of the translation table generated by Extract Translatable Text tool can be configured.

    Screenshot: Translation Table Format properties

    Click Modify to change the translation table format settings.

    You have the following options:

    1. Format: Word or Excel.
    2. Include file path and processed pages: this prints the full path to the processed drawing and the list of processed pages inside the translation table for easy reference.
    3. Prepare for CAT tool (Word format only): use this setting to prepare the translation table for importing into a CAT tool. You have several options:
      • Do not prepare (No CAT tool) – Use this option if the translation table does not need to be prepared for a CAT tool. If you use a CAT tool, the best way to translate the table is to copy the Translation column into a new document, translate the document, and then paste the translated cells over the cells in the Translation table so that you have source and translation side by side.
        This is the default option.
      • SDL Trados Studio, memoQ, Wordfast Pro, Wordfast Classic – If you use one of these options, TransTools will use tw4winExternal style to hide non-translatable parts of the table (i.e., instructions, heading row, original column and columns with extra information) and tw4winInternal style to mark formatting codes as non-translatable text. These options are recommended if you use one of these CAT tools. The translation table can be used inside your CAT tool without any extra preparation. After the translation table is translated and exported from your CAT tool, you can use it to merge translations into the drawing without any extra steps.
      • Memsource Cloud, Déjà Vu X3, Cafetran Espresso, CAT tool with hidden text filtering support – If one of these options is used, TransTools will use hidden font formatting to hide non-translatable parts of the table and hidden font formatting to mark formatting codes as non-translatable text. The translation table can be imported into your CAT tool without any extra preparation. When you import it into your CAT tool, make sure that hidden formatting is ignored in the file import settings.
      • Other CAT tool – When this option is selected, no extra formatting is applied to the translation table (besides special formatting of the formatting markers), so it is recommended to copy the Translation column into a new Word document, translate this document in your CAT tool, and then paste the translated cells over the cells in the Translation column before copying source and translation columns to the clipboard.
    4. Automatically save generated table in drawing's folder: if you check this box, TransTools will save the generated Word document automatically under the same location as the current drawing (with the same file name but with DOCX/DOC extension). This is possible if you are extracting text from a single Visio drawing only.

When the appropriate options have been selected, click Continue to generate a translation table which will be opened inside Microsoft Word or Excel (and saved if the appropriate option is activated). To exit, click Cancel.

Translating the translation table

There are several efficient ways to translate the translation table:

  • If you do not use a CAT tool, simply translate the source text inside the 2nd column.
  • If you use a CAT tool:

    • If the translation table is in Word format, simply import it into your CAT tool like any document. For this to work, make sure that Extract Translatable Text tool is configured to generate a translation table for your CAT tool.
    • If the translation table is in Excel format, copy the translatable cells from the 1st column to the 2nd column, then hide rows 1 to 3 and all columns except the Translation column. Translate the document in your CAT tool (the CAT tool should ignore hidden rows and columns by default). When the translated document is exported from the CAT tool, unhide the first column so that you can see both source and translation columns side by side in order to be able to copy both to the clipboard.
    • If your CAT tool is not listed among the options in Extract Translatable Text tool (for translation tables in Word format) or if your CAT tool does not support hidden rows/columns in Excel, you can copy the translatable cells from the 1st column into a separate document, translate it, then paste the translations into the 2nd column of the translation table, making sure that the source and target cells align correctly.

Translating drawing(s) using Translate using Translation Table tool

To translate a drawing using the final translation table, run Translate using Translation Table tool as described above. You will see the following dialogue:

Screenshot: Translate Using Translation Table dialogue

The dialogue has the following options:

  1. Files to process: This list will contain every sheet of every file opened in Microsoft Visio. Select sheets of individual drawings that you want to translate using the translation table. You can also click All / None to select / de-select all sheets in the list.
  2. Translation Table: Select the fully translated translation table file in Microsoft Word or Microsoft Excel format.

When the appropriate options have been selected, click Translate. To exit, close the dialogue or press Cancel.